ep's blog

Linux Kernel 'pipe.c' Local Privilege Escalation Vulnerability

http://www.securityfocus.com/bid/36901

"Linux kernel is prone to a local privilege-escalation vulnerability
that is caused by a NULL-pointer dereference.

Local attackers can exploit this issue to execute arbitrary code with
kernel-level privileges. Successful exploits will result in the complete
compromise of affected computers. Failed exploit attempts will result in
a denial-of-service condition. "

This affects RHEL, SuSE, etc. Kernels before 2.6.31.5.

BlackBerry Desktop Manager ActiveX Control Remote Code Execution Vulnerability

http://www.securityfocus.com/bid/36903/info

Versions of Research In Motion Blackberry Desktop Manager earlier than
5.0.1 are vulnerable to an ActiveX vulnerability that could lead to
remote arbitrary code execution.

Users should update their Desktop Manager application to the latest version.

Drupal LDAP Integration Cross Site Scripting and Authentication Bypass Vulnerabilities

http://www.securityfocus.com/bid/36860

"Drupal LDAP Integration is prone to a cross-site scripting
vulnerability and multiple authentication-bypass vulnerabilities.

Exploiting these issues could allow an attacker to steal cookie-based
authentication credentials, execute arbitrary code, and gain
unauthorized access to the affected application. "

This affects Drupal LDAP Integration 6.x-1.0-beta1, Drupal LDAP
Integration 5.x-1.4.

Pegasus Mail POP3 Response Remote Buffer Overflow Vulnerability

http://www.securityfocus.com/bid/36797/info

"Pegasus Mail is prone to a remote buffer-overflow vulnerability because
it fails to properly sanitize user-supplied input.

An attacker may exploit this issue to execute arbitrary code in the
context of the vulnerable application. Failed exploit attempts will
likely result in a denial-of-service condition.

Pegasus Mail 4.51 is vulnerable; other versions may also be affected."

Multiple vulnerabilities in Opera allow for remote code execution and URL obfuscation

http://blogs.zdnet.com/security/?p=4775

"Specially crafted domain names can cause a memory corruption in Opera,
which may lead to a crash. Successful exploitation can lead to execution
of arbitrary code."

"Opera may allow scripts to run on the feed subscription page, thereby
gaining access to the feeds object. This can be used for automatic
subscription of feeds, or reading other feeds."

Drupal - SA-CONTRIB-2009-085 - Insert Node - Cross Site Scripting

http://drupal.org/node/617400

"Description

The Insert Node module provides an input filter that enables a node to
be inserted within the body field of another node.

The module fails to sanitize the inserted node, making it vulnerable to
a cross site scripting (XSS) attack.
Versions affected

* Insert Node module versions for Drupal 5.x prior to Insert Node
5.x-1.2

Mozilla Firefox GIF Color Map Parsing Buffer Overflow Vulnerability

http://seclists.org/fulldisclosure/2009/Oct/338

"Remote exploitation of a buffer overflow in the Mozilla Foundation's
libpr0n image processing library allows attackers to execute arbitrary
code."

This has been fixed in the libpr0n libraries and pushed into Firefox
3.5.4. It is recommended that users upgrade to this version to avoid
exploitation.

If upgrade is not possible, users can disable automatically loading
images into their browser as a work around.

IE, Chrome, Safari duped by bogus PayPal SSL cert

http://www.theregister.co.uk/2009/10/05/fraudulent_paypay_certificate_pu...

A specially crafted SSL certificate was created that included a null
character in the Subject dn. This certificate was able to fool Internet
Explorer, Chrome and Safari into thinking that they were connected to a
legitimate Paypal site, when in fact, they were not.

Horde_Form_Type_image Arbitrary File Overwrite Vulnerability

http://seclists.org/fulldisclosure/2009/Sep/254

"PHP applications using the Horde_Form_Type_image form
element can be tricked into overwriting arbitrary files
writable by the webserver which might result in PHP
remote code execution"

This affects version 3.2.4 and below of Horde. It is recommended that
you upgrade to version 3.2.5 to avoid this vulnerability.

Thanks,
Brian

Pages