ep's blog

Mozilla Firefox GIF Color Map Parsing Buffer Overflow Vulnerability


"Remote exploitation of a buffer overflow in the Mozilla Foundation's
libpr0n image processing library allows attackers to execute arbitrary

This has been fixed in the libpr0n libraries and pushed into Firefox
3.5.4. It is recommended that users upgrade to this version to avoid

If upgrade is not possible, users can disable automatically loading
images into their browser as a work around.

IE, Chrome, Safari duped by bogus PayPal SSL cert


A specially crafted SSL certificate was created that included a null
character in the Subject dn. This certificate was able to fool Internet
Explorer, Chrome and Safari into thinking that they were connected to a
legitimate Paypal site, when in fact, they were not.

Horde_Form_Type_image Arbitrary File Overwrite Vulnerability


"PHP applications using the Horde_Form_Type_image form
element can be tricked into overwriting arbitrary files
writable by the webserver which might result in PHP
remote code execution"

This affects version 3.2.4 and below of Horde. It is recommended that
you upgrade to version 3.2.5 to avoid this vulnerability.


Fedora 'puppet' Package Insecure File Permissions Vulnerability


"The Fedora 'puppet' package is prone to an insecure file-permission

An attacker can exploit this issue to obtain sensitive information that
may aid in further attacks."

The Fedora Project has released updates to fix this issue. It is
recommended users of puppet on Fedora update as soon as possible.

Gpg4win Remote Denial of Service Vulnerability


"Gpg4win is prone to a remote denial-of-service vulnerability.

An attacker can exploit this issue to cause an affected application to
crash, denying service to legitimate users. "

This can be exploited by sending a specially crafted GPG message via
email to a user of Gpg4win. It will create a DoS by crashing Gpg4win.

VMware Products Page Fault Exception Local Privilege Escalation Vulnerability


Multiple VMware products are vulnerable to a page fault exception which
could lead to privilege escalation or denial of service.

This does not affect version 4.0 of ESX or ESXi.

An exploit is available. Running it as an unprivileged user on a guest
OS on VMware 3.5 caused the guest OS to kernel panic and lock up.

Mozilla Firefox and SeaMonkey MFSA 2009-{52..64} Multiple Vulnerabilities


"The Mozilla Foundation has released multiple advisories to address
vulnerabilities in Firefox and SeaMonkey.

An attacker can exploit these issues to obtain potentially sensitive
information, execute arbitrary code, elevate privileges, and cause
denial-of-service conditions."

US-CERT warns about free BlackBerry spyware app


A security director from Indonesia has created an application called
PhoneSnoop for the BlackBerry operating system that allows for remote
eavesdropping on phone calls. The software was written as a proof of
concept in order to show possibility attack methods for the platform.

The software would have to be installed through physical access or by
tricking the user.

New smarty packages fix several vulnerabilities


CVE-2008-4810, CVE-2009-1669, Vulnerabilities in Smarty can lead to
remote code exploitation.

Although this vulnerability specifically targets Debian installations,
it is a good time to check your current Smarty version. Also, if you
use Smarty, it is recommended that you subscribe to the Smarty announce
mailing list. This is a low-traffic list that will notify you of new
releases and bug fixes.