ep's blog

Ubuntu, Kubuntu, Edubuntu, and Xubuntu PAM vulnerability could lead to remote, unauthorized access


A non-default configuration of Pam under Ubuntu 8.10 and Ubuntu 9.04
could lead to successful authentication of unauthorized users to an
Ubuntu machine.

"The problem can be corrected by upgrading your system to the following
package versions:

Ubuntu 8.10:

libpam-runtime 1.0.1-4ubuntu5.6

Ubuntu 9.04:

libpam-runtime 1.0.1-9ubuntu1.1"

Pidgin's libpurple vulnerable to multiple denial of service attacks.


Successful exploits of a libpurple vulnerability will lead to crashes in

"Pidgin Libpurple 2.6.1 and prior versions are affected."

This affects the IRC, XMPP and MSN chat clients which use libpurple. It
is recommended that users upgrade their Pidgin/libpurple installations
to a newer, fixed version.

WordPress worm leads to site defacement


WordPress is warning its users of a new worm that is currently
spreading. If you have not installed one of the last two updates,
released on August 3 and August 12, you are vulnerable to the worm.

This worm posts spam as an admin user.

It is recommended that all WordPress sites update to the latest version.

This is a Severity 1, Priority 1 issue.

Java for Mac OS X 10.5 Update 5


A major java update for Mac OS X 10.5 was released yesterday by Apple.
It addresses 17 unique Common Vulnerabilities and Exposures (CVE) in
Java ranging from privilege escalation, arbitrary code execution and
unexpected application termination (DoS).

It is recommended that all Macintosh OS X 10.5 users update their
version of Java and ensure that all older versions of Java have been

Upgrading to Mac OSX 10.6 (Snow Leopard) includes a downgrade to a vulnerable version of Adobe Flash


For anyone who has upgraded to Snow Leopard, be aware that the version
of Flash that comes with it has a vulnerability.

It is recommended that users of Snow Leopard upgrade to the latest
version of Adobe Flash.


TWiki Cross-Site Scripting and Command Injection Vulnerabilities


Versions of Twiki earlier than 4.2.4 are vulnerable to code execution
due to improper data filtering.

It is recommended to update to the latest version of twiki, currently 4.3.

It should be noted this is a Priority 1, Severity 1 issue.

Priority 1: This vulnerability is the most severe. It is actively being
exploited, or exploitation is imminent. Other outside businesses or
schools are actively being exploited.

Buffer Overflow and Integer Underflow Vulnerabilities in OpenOffice Writer could lead to arbitrary code execution


"Secunia Research has discovered a vulnerability in OpenOffice.org,
which can be exploited by malicious people to potentially compromise
a user's system.

The vulnerability is caused by a boundary error when parsing certain
records and can be exploited to cause a heap-based buffer overflow via
a specially crafted document.