ep's blog

Apple Safari for Windows Prior to 4.0.5 Integer Overflow Vulnerability


"Safari is prone to an integer overflow vulnerability.

Successfully exploiting this issue may allow remote attackers to execute
arbitrary code in the context of the application. Failed attacks will
likely cause denial-of-service conditions."

Apple has released version 4.0.5 of the software. It is recommended
that users update to this release.


Apple iPhone Malformed VML Data Remote Code Execution Vulnerability


A POC exploit has been written that can crash Safari on the Apple iPhone
when the user visits a maliciously crafted webpage. This affects:

Apple iPhone 3.1.3
Apple iPhone 3.1.2
Apple iPhone 3.0.1
Apple iPhone 3.1
Apple iPhone 3.0

The POC claims the ability to execute arbitrary code via this exploit.
Apple has not yet released a patch or verified this issue.

90 percent of Windows 7 flaws fixed by removing admin rights


Thanks to David for this article.  In it Ars Technica covers a report by BeyondTrust on Windows vulnerabilities in 2009.  It compares the vulnerability on Windows 2000 through Windows 7, and whether a user has admin rights or not.

If nothing else, this article speaks to why regular users are better protected if they run without administrative privileges.


Broadcom NetXtreme Ethernet Card possible remote vulnerability


"A buffer overflow vulnerability exists in the Broadcom NetXtreme
management firmware. This vulnerability may allow a remote attacker to
execute arbitrary code on an affected device."

This affects the firmware on the card itself, regardless of whether the
machine is turned on or off. Both Dell and HP use these cards in their
desktops and servers.

The following devices/firmwares are affected:

Would You Have Spotted this ATM Fraud?


I don't know about you, but I cringe every time I go to an ATM nowadays.  "Why?" you ask.  Because I've heard of a lot of reports and seen a lot of pictures of ATM skimmers.  These devices attach to the front of an ATM where your card goes in.  When you insert your card, they scan it as well as the ATM.  Now they can create a copy of your card.

Adobe Flash Media Server Directory Traversal Vulnerability


"Adobe Flash Media Server is prone to a directory-traversal
vulnerability because it fails to sufficiently sanitize user-supplied input.

Exploiting this issue can allow an attacker to load arbitrary Dynamic
Linked Libraries (DLLs) present on the server. This could help the
attacker launch further attacks. "

This affects Adobe Flash Media Server 3.5.2 and prior.
This affects Adobe Flash Media Server 3.0.4 and prior.

GNU Tar and GNU Cpio Remote Buffer Overflow Vulnerability


"GNU Tar and GNU Cpio are prone to a remote buffer-overflow
vulnerability because the applications fail to perform adequate boundary
checks on user-supplied data.

An attacker can exploit this issue to execute arbitrary code with the
privileges of the user running the affected application. Failed exploit
attempts will result in a denial-of-service condition.

This issue affects the following:

MFSA 2010-08 Firefox 3.6.2 released early


Mozilla was originally going to release 3.6.2 on March 30.

"Firefox 3.6.2 fixes the following issues found in previous versions of
Firefox 3.6:

* Fixed a critical security issue that could potentially allow
remote code execution (see bug 552216).
* Fixed several additional security issues.
* Fixed several stability issues."

It is recommended that all Firefox 3.6.x users update to 3.6.2.