ep's blog

GNU Tar and GNU Cpio Remote Buffer Overflow Vulnerability

http://www.securityfocus.com/bid/38628/info

"GNU Tar and GNU Cpio are prone to a remote buffer-overflow
vulnerability because the applications fail to perform adequate boundary
checks on user-supplied data.

An attacker can exploit this issue to execute arbitrary code with the
privileges of the user running the affected application. Failed exploit
attempts will result in a denial-of-service condition.

This issue affects the following:

MFSA 2010-08 Firefox 3.6.2 released early

http://www.mozilla.com/en-US/firefox/3.6.2/releasenotes/

Mozilla was originally going to release 3.6.2 on March 30.

"Firefox 3.6.2 fixes the following issues found in previous versions of
Firefox 3.6:

* Fixed a critical security issue that could potentially allow
remote code execution (see bug 552216).
* Fixed several additional security issues.
* Fixed several stability issues."

It is recommended that all Firefox 3.6.x users update to 3.6.2.

CVE-2010-0419 kvm: emulator privilege escalation segment selector check

http://www.securityfocus.com/bid/38467

"The Linux kernel is prone to a privilege-escalation vulnerability
affecting the Kernel-based Virtual Machine (KVM).

A guest user could exploit this issue to gain elevated privileges on the
guest operating system or crash the guest."

https://rhn.redhat.com/errata/RHSA-2010-0126.html

It is recommended that kvm package updates be applied to mitigate this
vulnerability.

Opera Browser "Content-Length" Header Buffer Overflow Vulnerability in newly released 10.50

http://secunia.com/advisories/38820/

Two new vulnerabilities have been found in 10.50 and earlier versions.
The first can cause a DoS, the second could allow for remote code execution.

No patches are available as of yet. Recommendations from the Secunia
report are "do not browse untrusted websites or follow untrusted links."
This is a good recommendation in general. Other recommendations have
been to stop using Opera all together until an official patch is available.

Apache HTTP Server (httpd) 2.2.15 Released - includes security fixes

http://www.apache.org/dist/httpd/Announcement2.2.html

Version 2.2.15 fixes these three vulnerabilities.

* important: mod_isapi module unload flaw CVE-2010-0425 (Windows)
* low: Subrequest handling of request headers (mod_headers) CVE-2010-0434
* moderate: mod_proxy_ajp DoS CVE-2010-0408

It is recommended that Apache be updated to the latest code version.

Thanks,
ep

SpamAssassin Milter Plugin 'mlfi_envrcpt()' Remote Arbitrary Command Injection Vulnerability

http://www.securityfocus.com/bid/38578/info

A lack of input sanitization could lead to arbitrary code execution on
systems using the spamassassin milter plugin. The exploit given
specifically targets PostFix installations, however, this issue may
affect other mail services as well.

SpamAssassin Milter Plugin 0.3.1 is affected, although other versions
may be affected as well. v0.3.1 was released in April 2006.

SA-CORE-2010-001 - Drupal core - Multiple vulnerabilities

http://drupal.org/node/731710

Multiple vulnerabilities in Drupal 6.x before version 6.16 and Drupal
5.x before version 5.22 have been fixed in the latest release. These
vulnerabilities include:

* Installation cross site scripting
* Open redirection
* Locale module cross site scripting
* Blocked user session regeneration

Priority 4: This vulnerability has a lower probability of exploitation,
but should still be mitigated.

Samba 'client/mount.cifs.c' Local Denial of Service Vulnerability

http://www.securityfocus.com/bid/38326/info

"Samba is prone to a local denial-of-service vulnerability.

A local attacker can exploit this issue to corrupt system files,
resulting in a denial-of-service condition. Other attacks may be possible.

Samba 3.4.5 and earlier are vulnerable."

It is recommended to update to the latest version of samba to avoid this
vulnerability. Due to the nature of this vulnerability, it should be
treated as:

Pages