ep's blog

CVE-2010-0419 kvm: emulator privilege escalation segment selector check


"The Linux kernel is prone to a privilege-escalation vulnerability
affecting the Kernel-based Virtual Machine (KVM).

A guest user could exploit this issue to gain elevated privileges on the
guest operating system or crash the guest."


It is recommended that kvm package updates be applied to mitigate this

Opera Browser "Content-Length" Header Buffer Overflow Vulnerability in newly released 10.50


Two new vulnerabilities have been found in 10.50 and earlier versions.
The first can cause a DoS, the second could allow for remote code execution.

No patches are available as of yet. Recommendations from the Secunia
report are "do not browse untrusted websites or follow untrusted links."
This is a good recommendation in general. Other recommendations have
been to stop using Opera all together until an official patch is available.

Apache HTTP Server (httpd) 2.2.15 Released - includes security fixes


Version 2.2.15 fixes these three vulnerabilities.

* important: mod_isapi module unload flaw CVE-2010-0425 (Windows)
* low: Subrequest handling of request headers (mod_headers) CVE-2010-0434
* moderate: mod_proxy_ajp DoS CVE-2010-0408

It is recommended that Apache be updated to the latest code version.


SpamAssassin Milter Plugin 'mlfi_envrcpt()' Remote Arbitrary Command Injection Vulnerability


A lack of input sanitization could lead to arbitrary code execution on
systems using the spamassassin milter plugin. The exploit given
specifically targets PostFix installations, however, this issue may
affect other mail services as well.

SpamAssassin Milter Plugin 0.3.1 is affected, although other versions
may be affected as well. v0.3.1 was released in April 2006.

SA-CORE-2010-001 - Drupal core - Multiple vulnerabilities


Multiple vulnerabilities in Drupal 6.x before version 6.16 and Drupal
5.x before version 5.22 have been fixed in the latest release. These
vulnerabilities include:

* Installation cross site scripting
* Open redirection
* Locale module cross site scripting
* Blocked user session regeneration

Priority 4: This vulnerability has a lower probability of exploitation,
but should still be mitigated.

Samba 'client/mount.cifs.c' Local Denial of Service Vulnerability


"Samba is prone to a local denial-of-service vulnerability.

A local attacker can exploit this issue to corrupt system files,
resulting in a denial-of-service condition. Other attacks may be possible.

Samba 3.4.5 and earlier are vulnerable."

It is recommended to update to the latest version of samba to avoid this
vulnerability. Due to the nature of this vulnerability, it should be
treated as:

APC Network Management Card web interface vulnerable to cross-site scripting and cross-site request forgery


"The web management interface for the APC Network Monitoring Card (NMC)
used in various APC devices contains cross-site scripting (XSS) and
cross-site request forgery (CSRF/XSRF) vulnerabilities. By convincing a
victim to load a specially crafted URL while authenticated to an NMC, an
attacker could obtain credentials or perform certain actions as the
victim, including turning off the NMC-based device and any systems
attached to it. "

Important sudo security update for RHEL


"An updated sudo package that fixes two security issues is now available for
Red Hat Enterprise Linux 5.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

The sudo (superuser do) utility allows system administrators to give
certain users the ability to run commands as root.