Multiple vulnerabilities found in Mozilla Firefox

http://secunia.com/advisories/24205/ It is recommended to upgrade to 1.5.0.10 or 2.0.0.2. These vulnerabilities include security restrictions bypass, cross site scripting, disclosure of personal data and even (possibly) system compromise.