Multiple Vulnerabilities patched in Mozilla Firefox 2.0

http://www.securityfocus.com/brief/678 - Ten security holes were patched in Firefox. Exploits including information gathering, rogue script privilege escalation and other problems were fixed in version 2.0.0.12. It is recommended that all Firefox 2.0 users upgrade to version 2.0.0.12.