RHEL cups security update

http://rhn.redhat.com/errata/RHSA-2009-1595.html

"A use-after-free flaw was found in the way CUPS handled references in its
file descriptors-handling interface. A remote attacker could, in a
specially-crafted way, query for the list of current print jobs for a
specific printer, leading to a denial of service (cupsd crash).
(CVE-2009-3553)

Several cross-site scripting (XSS) flaws were found in the way the CUPS web
server interface processed HTML form content. If a remote attacker could
trick a local user who is logged into the CUPS web interface into visiting
a specially-crafted HTML page, the attacker could retrieve and
potentially modify confidential CUPS administration data. (CVE-2009-2820)"

It is recommended that servers/workstations using cups upgrade to the
latest version.

Thanks,
ep