Linux Kernel 'net/mac80211/' Multiple Remote Denial of Service Vulnerabilities

http://www.securityfocus.com/bid/37170/info

"The Linux Kernel is prone to multiple remote denial-of-service
vulnerabilities.

An attacker can exploit these issues to cause a kernel panic, denying
service to legitimate users."

It should be noted that this affects the mac80211 code in the kernel
which deals specifically with the 802.11 wireless lan standard.

This appears to affect every 2.6 kernel up to 2.6.32-rc7. A patch has
been commited upstream fixing CVE-2009-4026 and CVE-2009-4027.

http://www.redhat.com/security/data/cve/CVE-2009-4026.html
http://www.redhat.com/security/data/cve/CVE-2009-4027.html

Red Hat has not yet released this patched version of the kernel. All
Linux users should expect an update in the near future to fix this
issue. Be on the lookout for the patch and update when possible on all
machines using wireless connections.