5 critical patches for VMware ESXi 4.0.0 (Availability and Integrity patches)

https://www.vmware.com/mysupport/s3portal.portal?_nfpb=true&_windowLabel...

Various bugs have been fixed in the updates available in these patches.
Most of the bugs will lead to denial of service by VMware hosts
shutting down due to hardware incompatibility or possible data corruption.

It is recommended that ESXi 4.0.0 hosts be updated for these patches.

VMware asserts that by applying the latest patch ESXi400-200909001, you
will get all the previous patches. It is suggested that you use Host
Update (packaged with vSphere Client) to do the update even though the
patch documentation suggests using the CLI product.

I personally have not tested the upgrade process, yet, but am planning
to today. I will let people know how my experience goes today.

VMware will start announcing patch updates on October 23, 2009.