Upgrading to Mac OSX 10.6 (Snow Leopard) includes a downgrade to a vulnerable version of Adobe Flash