Multiple Vulnerabilities in Horde v3.1.5