Welcome to the Network Security website at the IAS

This website is intended to bring you the latest news, how to's, tools and resources in Information Security.  Security Awareness of our Faculty, Members and Staff is key in creating a safer computing environment.

The three major Principles of Information Security, Availability, Integrity and Confidentiality, will be covered throughout the security awareness program at the Institute.  For a description of these principles, please see our About section.

In keeping with the spirit of the Institute, I encourage questions and open discussions about security.  And if you discover anything out of the ordinary, please feel free to bring it to my attention so that we can work together to create a more productive, safer environment.

Thanks,
Brian Epstein <security@ias.edu>
twitter: @epepepep


VMSA-2010-0018: VMware hosted products and ESX patches resolve multiple security issues

http://www.vmware.com/security/advisories/VMSA-2010-0018.html

"1. Summary

VMware hosted products and ESX patches resolve multiple security
issues.

2. Relevant releases

VMware Workstation 7.1.1 and earlier,
VMware Workstation 6.5.4 and earlier,
VMware Player 3.1.1 and earlier,
VMware Player 2.5.4 and earlier,

VMware Fusion 3.1.1 and earlier,

APPLE-SA-2010-11-22-1 iOS 4.2 for iPhone, iPod Touch, iPad

http://support.apple.com/kb/HT4456

Apple has released over 80 patches in its latest update of iOS, the
operating system for its iPhone, iPod Touch, iPad devices.
Vulnerabilities mitigated in this release include: arbitrary code
execution, unexpected application termination and unexpected system
shutdown.

It is recommended that users of these devices update to the latest
version of iOS to avoid exploitation.

Thanks,
Brian

APPLE-SA-2010-11-22-1 iOS 4.2 for iPhone, iPod Touch, iPad

http://support.apple.com/kb/HT4456

Apple has released over 80 patches in its latest update of iOS, the
operating system for its iPhone, iPod Touch, iPad devices.
Vulnerabilities mitigated in this release include: arbitrary code
execution, unexpected application termination and unexpected system
shutdown.

It is recommended that users of these devices update to the latest
version of iOS to avoid exploitation.

Thanks,
Brian

APPLE-SA-2010-11-18-1 Safari 5.0.3 and Safari 4.1.3

http://support.apple.com/kb/HT4455
http://support.apple.com/kb/HT4455

Safari 5.0.3 and Safari 4.1.3 is now available and fix various security
vulnerabilities including: unexpected application termination, arbitrary
code execution, surreptitious user tracking, disclosure of image data,
location bar address spoofing, location bar arbitrary history insertion,
undesired DNS prefetching.

APPLE-SA-2010-11-18-1 Safari 5.0.3 and Safari 4.1.3

http://support.apple.com/kb/HT4455
http://support.apple.com/kb/HT4455

Safari 5.0.3 and Safari 4.1.3 is now available and fix various security
vulnerabilities including: unexpected application termination, arbitrary
code execution, surreptitious user tracking, disclosure of image data,
location bar address spoofing, location bar arbitrary history insertion,
undesired DNS prefetching.

OpenSSL buffer overflow vulnerability

http://www.openssl.org/news/secadv_20101116.txt

"All versions of OpenSSL supporting TLS extensions contain this
vulnerability including OpenSSL 0.9.8f through 0.9.8o, 1.0.0, 1.0.0a
releases.

Any OpenSSL based TLS server is vulnerable if it is multi-threaded and
uses OpenSSL's internal caching mechanism. Servers that are
multi-process and/or disable internal session caching are NOT affected.

OpenSSL buffer overflow vulnerability

http://www.openssl.org/news/secadv_20101116.txt

"All versions of OpenSSL supporting TLS extensions contain this
vulnerability including OpenSSL 0.9.8f through 0.9.8o, 1.0.0, 1.0.0a
releases.

Any OpenSSL based TLS server is vulnerable if it is multi-threaded and
uses OpenSSL's internal caching mechanism. Servers that are
multi-process and/or disable internal session caching are NOT affected.

Security updates available for Adobe Reader and Acrobat

http://www.adobe.com/support/security/bulletins/apsb10-28.html

"Critical vulnerabilities have been identified in Adobe Reader 9.4 (and
earlier versions) for Windows, Macintosh and UNIX, and Adobe Acrobat 9.4
(and earlier 9.x versions) for Windows and Macintosh. These
vulnerabilities could cause the application to crash and potentially
allow an attacker to take control of the affected system."

Pages