Welcome to the Network Security website at the IAS

This website is intended to bring you the latest news, how to's, tools and resources in Information Security.  Security Awareness of our Faculty, Members and Staff is key in creating a safer computing environment.

The three major Principles of Information Security, Availability, Integrity and Confidentiality, will be covered throughout the security awareness program at the Institute.  For a description of these principles, please see our About section.

In keeping with the spirit of the Institute, I encourage questions and open discussions about security.  And if you discover anything out of the ordinary, please feel free to bring it to my attention so that we can work together to create a more productive, safer environment.

Thanks,
Brian Epstein <security@ias.edu>
twitter: @epepepep


Java for Mac OS X 10.5 Update 5

http://support.apple.com/kb/HT3851

A major java update for Mac OS X 10.5 was released yesterday by Apple.
It addresses 17 unique Common Vulnerabilities and Exposures (CVE) in
Java ranging from privilege escalation, arbitrary code execution and
unexpected application termination (DoS).

It is recommended that all Macintosh OS X 10.5 users update their
version of Java and ensure that all older versions of Java have been
removed.

Upgrading to Mac OSX 10.6 (Snow Leopard) includes a downgrade to a vulnerable version of Adobe Flash

http://blogs.adobe.com/psirt/2009/09/flash_player_update_and_snow_l.html

For anyone who has upgraded to Snow Leopard, be aware that the version
of Flash that comes with it has a vulnerability.

It is recommended that users of Snow Leopard upgrade to the latest
version of Adobe Flash.

Thanks,
Brian

Upgrading to Mac OSX 10.6 (Snow Leopard) includes a downgrade to a vulnerable version of Adobe Flash

http://blogs.adobe.com/psirt/2009/09/flash_player_update_and_snow_l.html

For anyone who has upgraded to Snow Leopard, be aware that the version
of Flash that comes with it has a vulnerability.

It is recommended that users of Snow Leopard upgrade to the latest
version of Adobe Flash.

Thanks,
Brian

Upgrading to Mac OSX 10.6 (Snow Leopard) includes a downgrade to a vulnerable version of Adobe Flash

http://blogs.adobe.com/psirt/2009/09/flash_player_update_and_snow_l.html

For anyone who has upgraded to Snow Leopard, be aware that the version
of Flash that comes with it has a vulnerability.

It is recommended that users of Snow Leopard upgrade to the latest
version of Adobe Flash.

Thanks,
Brian

TWiki Cross-Site Scripting and Command Injection Vulnerabilities

http://secunia.com/advisories/33040

Versions of Twiki earlier than 4.2.4 are vulnerable to code execution
due to improper data filtering.

It is recommended to update to the latest version of twiki, currently 4.3.

It should be noted this is a Priority 1, Severity 1 issue.

Priority 1: This vulnerability is the most severe. It is actively being
exploited, or exploitation is imminent. Other outside businesses or
schools are actively being exploited.

TWiki Cross-Site Scripting and Command Injection Vulnerabilities

http://secunia.com/advisories/33040

Versions of Twiki earlier than 4.2.4 are vulnerable to code execution
due to improper data filtering.

It is recommended to update to the latest version of twiki, currently 4.3.

It should be noted this is a Priority 1, Severity 1 issue.

Priority 1: This vulnerability is the most severe. It is actively being
exploited, or exploitation is imminent. Other outside businesses or
schools are actively being exploited.

TWiki Cross-Site Scripting and Command Injection Vulnerabilities

http://secunia.com/advisories/33040

Versions of Twiki earlier than 4.2.4 are vulnerable to code execution
due to improper data filtering.

It is recommended to update to the latest version of twiki, currently 4.3.

It should be noted this is a Priority 1, Severity 1 issue.

Priority 1: This vulnerability is the most severe. It is actively being
exploited, or exploitation is imminent. Other outside businesses or
schools are actively being exploited.

Buffer Overflow and Integer Underflow Vulnerabilities in OpenOffice Writer could lead to arbitrary code execution

http://secunia.com/secunia_research/2009-26/
http://secunia.com/secunia_research/2009-27/

"Secunia Research has discovered a vulnerability in OpenOffice.org,
which can be exploited by malicious people to potentially compromise
a user's system.

The vulnerability is caused by a boundary error when parsing certain
records and can be exploited to cause a heap-based buffer overflow via
a specially crafted document.

Buffer Overflow and Integer Underflow Vulnerabilities in OpenOffice Writer could lead to arbitrary code execution

http://secunia.com/secunia_research/2009-26/
http://secunia.com/secunia_research/2009-27/

"Secunia Research has discovered a vulnerability in OpenOffice.org,
which can be exploited by malicious people to potentially compromise
a user's system.

The vulnerability is caused by a boundary error when parsing certain
records and can be exploited to cause a heap-based buffer overflow via
a specially crafted document.

Buffer Overflow and Integer Underflow Vulnerabilities in OpenOffice Writer could lead to arbitrary code execution

http://secunia.com/secunia_research/2009-26/
http://secunia.com/secunia_research/2009-27/

"Secunia Research has discovered a vulnerability in OpenOffice.org,
which can be exploited by malicious people to potentially compromise
a user's system.

The vulnerability is caused by a boundary error when parsing certain
records and can be exploited to cause a heap-based buffer overflow via
a specially crafted document.

Pages